Adding a Hard Drive – “If All The Parameters Are In Place”

Adding a new Hard drive to the system should be easy and if all the parameters are in place, it will be. That’s the important thought however, “If all the parameters are in place…”

We received a Western Digital Caviar Green 3TB Internal Drive in to test out in the Media Center PC we are putting together and after putting the Motherboard and Processor in place, installing Memory, the Main Hard Drive (Western Digital 500GB 7200RPM 16MB Cache), Video Card and Windows 7 X64 (We’ll be testing with X32 as well) we were excited to add the WD Caviar Green 3TB Internal to the fold. After putting the rails on the drive and cables we booted the system up which located the drive. We selected the Create New Volume and after deciding to label the drive and choosing it as Drive M (For Media) we proceeded to Quick Format the Device. After about 30seconds the Quick Format failed and we then unchecked the box for Quick Format and decided it was possibly best to perform a detail and exact format. We knew this means it will take longer, but we were not expecting what happened next.

We started the format at 9:15am on Sunday 12/19/2010 and on Monday 12/20/2010 at 8:15am we were at 1%. Looking at the Storage Manager we could see that Windows 7 and the Intel Board could locate and visually see the drive however this was by no means normal. Without becoming all Sheldon on ya, this could in fact take 2 months, 23 days, 7 hours and 11.5 Minutes, give or take a month to format. Western Digital had sent a HPA Adaptor card which is a part of the 3TB Internal Drives, also the 2.5TB drives ship with this little card which plugs into the available PCI Express Port. We didn’t install the card since the Intel Board, the DH57DD was so new we assumed it should have no problem with the capacity of the drive.

If you aren’t aware, There are limitations in size for some boards accessing over 2.19TB. This little card that WD includes will help some boards be able to address the drive and welcome it to the hardware fold. WD even includes the plug in card with low riser and full size bracket for the smaller towers and regular sizes available. We plugged the card in, hooked up the drive and upon boot, the card was identified but the drive wasn’t. We let it boot and sure enough, nada was in the available drives. We shut it down, made sure the SATA Cable and power cable were connected firmly and rebooted. This time, the drive was seen and we proceeded to boot into Windows and begin the steps to reformat.

Once we deleted the previous volume and then reattempted in Quick Format Mode, it failed. We reattempted by deselecting the Quick Format and could see right away, the format was going to be a long process. Something just wasn’t right. We revisited the Western Digital website which features a very good video on adding a secondary drive with the WD Caviar Green 3TB and saw that all the steps we’d performed we’re inline. After a cup of coffee and racking the brain we decided to try one other step we hadn’t done, changing out the SATA Cable. We had provided this cable as the ones that came with the board were both used up.

Over the years you tend to amass a large quantity of cables and power cords, I always wonder if somewhere I forgot to hook up a cable because why do I have an extra!?
I located a SATA cable and connected it, rebooted the system went through the steps of deleting the old volume, recreating and performing a Quick Format. Viola! (Walla! for those not immersed in French..) Our Drive formatted and quickly. So, before you go calling Tech Support or heading back to Frys or Best Buy check the SATA cable to make sure that it isn’t the culprit. Also remember to toss the other cable since leaving it around will just cause you to put it in another system. Hopefully this helps somebody!!

Andy

Leave a Reply